Drupal 8.8 abandonara definitivamente PHP 5

Imagen
Hombre observando el horizonte

Hace tiempo que se anunció que se eliminaría el soporte de PHP 5 en Drupal 8 debido a que no quieren mantener el soporte de dependencias obsoletas. Originalmente se anunció que se abandonaría PHP 5 para Drupal 8.7, pero decidieron, no permitir nuevas instalaciones en versiones anteriores pero que siguiera funcionando bajo PHP 5.

Pues bien, Drupal 8.8 definitivamente abandonará el soporte para PHP 5 y ya no se podrá instalar ni tampoco usar en versiones antiguas de PHP, es decir, las anteriores a PHP 7. Esto también supondrá que actualicen algunas dependencias externas, que no podían actualizar debido a que todavía se soportaba PHP 5.

Ya han realizado el commit para este cambio en la rama de Drupal 8.8, y no se pasará a Drupal 8.7, de modo que podemos estar tranquilos hasta diciembre por lo menos si tenemos un sitio antiguo que todavía está en un servidor con PHP 5, aunque si aguantamos con las actualizaciones de seguridad, hasta junio del 2020 aún tenemos tiempo.

Como se ha comentado antes, este cambio permitirá actualizar algunas librerías externas como PHPunit de la versión 4 a la 6, actualizar a Twig 3 cuando sea lanzado en los próximos meses o Symfony 4/5.

Mejor dejar atrás PHP 5 cuanto antes

A pesar de que aun tengamos soporte para un tiempo en Drupal 8, realmente, deberíamos haber dejado hace tiempo atrás PHP 5 en nuestros servidores, ya que en diciembre del 2018 recibió su última actualización y oficialmente finalizado su soporte, ya nunca más habrá actualizaciones, ni de seguridad.

 

Artículos relacionados: