Se ha eliminado el soporte para PHPUnit 4 en Drupal 8.8

Imagen
Avion rojo de juguete en una mesa

Parece que últimamente las noticias tratan sobre dejar de soportar distintas tecnologías o versiones en Drupal 8, y es que si hace unos días hablábamos del fin de soporte de PHP 5 en Drupal 8.8, ahora tenemos que mencionar, el reemplazo de PHPUnit 4.8 por PHPUnit 6.5.

Olvidarse de PHP 5 aparentemente va a implicar la actualización de muchas tecnologías que actualmente usa Drupal 8. Ya que a algunas (como PHPUnit) estaba atado debido al uso de PHP 5, pero ahora que ya no se le necesitara mas, toca ponerse al día.

Ademas, teniendo en cuenta, que la próxima versión, se espera que sea la ultima antes del lanzamiento de Drupal 9, seguramente veamos cómo se actualizan todas las dependencias, incluyendo la mas importante, Symfony.

Volviendo a PHPUnit, se ha pasado de la 4.8 a la 6.5, aunque ya están trabajando en el soporte para la versión 7, la cual ni siquiera es la mas reciente, pero sí esta soportada, al contrario de la rama 6.x, que se abandono en febrero de este año. A sí que, aunque utilicemos una versión más nueva, seguiremos utilizando una obsoleta.

Un futuro de actualizaciones:

Seguramente esta no sea la ultima noticia que veamos antes de que se lance Drupal 8.8 en diciembre, ya que al establecer como versión mínima PHP 7.0, ahora se podrá actualizar a Twig 2 y Symfony 4 (aunque este ultimo, necesite PHP 7.1), pero posiblemente se coloque como versión opcional en composer, para que se actualice si nuestro entorno lo soporta.

Artículos relacionados: